Importing a contacts csv export

I exported my contacts from Outlook Express on my old computer and now I want to import it into Outlook on my new computer. The file is in csv-format but when I try to import it into Outlook, I’m being prompted to Map Custom Fields but everything is just on a single line.
How can I get my contacts into Outlook?

I’m not sure whether I should call this a bug or a feature but luckily the solution is quite easy. For a change, let’s start with the solution and then I’ll explain my dilemma of whether to call this a bug or a feature.

Solution
The issue is that instead of commas ( , ) being used as a separator, you probably see semi-colons ( ; ) being used instead. So replace the semi-colons for commas and you’re done. The easiest is to do this in Notepad;

  1. Open Notepad.
  2. Edit-> Replace…
  3. Find what: ;
    Replace with: ,
  4. Press Replace All.
  5. Save the file and close Notepad.
  6. Go back to Outlook and import the file.

The bug or feature dilemma
The reason why Outlook Express (OE) or even Windows Mail (WM) and Windows Live Mail (WLM) used a semi-colon as a separator instead of a comma is because that is what is specified in your Regional Settings in Windows to be used as the list separator. If this was set to a comma, you probably wouldn’t have been reading this ;-)

Outlook however expects a comma as a separator in a csv-file as that is what the file format stands for; comma separated value. Should OE, WM or WLM look at your configured list separator instead and use that? Should Outlook? It would break interoperability between systems if the format of a file is depended on end-user configuration. Are OE, WM and WLM to blame here for not respecting the meaning of csv? In essence, OE, WM and WLM export to the dsv-format; delimiter separated value. In this format the choice of the delimiter is not restricted to a comma.

However, as I said, you can configure the delimiter in your Regional Settings in Windows which would make it a feature again and will enable to OE, WM and WLM to create a proper csv-file again.

To change your list separator value in Windows;

  1. Open Control Panel.
  2. Open the Regional and Language Options applet.
    In Windows XP Category view you’ll find it in the category; Date, Time, Language, and Regional Options.
    In Windows Vista and Windows 7 you’ll find it under; Clock, Language and Region.
  3. On the Formats tab click; Customize this format…
  4. In the drop down list for List separator you can either select the comma or type it in the box if it is not listed.
  5. Now, when you export from OE, WM or WLM, you’ll create a proper csv-file.

So, would you call it a bug or a feature? Should OE, WM and WLM always use the comma and not look at your list separator value or should they rename the file format to dsv instead?

I think I’d prefer the first solution as that is what Outlook expects as well when importing and that is simply what the csv-format stands for. The thing is, files with another delimiter than a comma usually are named *.csv as well so the confusion remains when getting another file for import.

My advise;
Always double check the delimiter being used before importing anything. If the delimiter is not what is being expected and you cannot configure the delimiter upon importing (like Excel supports), then fire up Notepad and use its Replace function. The dilemma might be complex, at least the workaround is easy ;-)

Sperry Software
Use "BH93RF24" to get a discount when ordering!