Email empty when changing signature

After composing my email I changed my signature. When doing that it deleted all the text from the message. What happened and how can I prevent this from happening?

This applies to Outlook 2007 or when having Word set as your default email editor in previous versions of Outlook. When you start typing a new message, you already see your email signature. In the background Outlook divides your message into a message and a signature section. When you change your signature, that entire section will get replaced with the new signature.

Somehow you ended up typing in the signature area. I find myself doing that when I think I should add a few more lines at the end of the message. To create some space to type in, I put my cursor right in front of the beginning of my signature and press Enter twice so I have enough space to write in. In this case, I would now be typing in the signature area instead of the message area.

Two ways to notice this are;

  • automatic spell check is not working (misspelled words don’t get underlined). Ok granted, not helpful if you type without errors ;-)
  • the right-click menu doesn’t show the usual options but only shows the names of the other signatures

There is no good way to prevent this from happening. There is no visual alert or visual line between the sections. Try to teach yourself not to add blank lines by placing the cursor in front of your signature and press Enter but by placing your cursor at the end of your last sentence and press Enter. Another method is to teach yourself to directly change your signature when you start composing.

Of course, when you do find yourself in a situation when suddenly all your typed text vanishes right in front of you when changing your signature; DON’T PANIC! Simply press the Undo button and your text will return. Then cut and paste your text out of the signature area into the message area. After this you can change your signature and the typed text will stay.

Sperry Software
Use "BH93RF24" to get a discount when ordering!